Определите количество чисел, для записи которых в восьмеричной системе 
счисления требуется ровно 11 цифр, ровно 3 из которых – нечётные, 
и никакие две нечётные цифры не стоят рядом


import itertools as I
N, H = 0,0
for i in I.product('нч',repeat=11):
    s = ''.join(i)
    if s.count('н')==3 and not 'нн' in s:
        if s[0]=='н': N+=1
        if s[0]=='ч': H+=1
print(H*3*4**10+N*4**11)
